New Things

To quell my mounting impatience, the mighty and powerful Liz sent me a scan of the brand spanky new Realms of Fantasy review. Since the magazine’s site hasn’t been updated with the September content yet, I can’t link you to the full text — but I’ve excerpted the beginning and added it to my reviews page, if you want to take a peek.

In other news, my agent was contacted by a movie producer earlier this week. I guess someone read the Publishers Weekly review and wanted to see the book, so Lantz has dutifully sent along an ARC. I’m not as excited as you might think; this has happened twice before, and nothing came of it. Once it was declined in the midst of all the legal crap with Mad Bruce, and the second time it was dropped because the interested party got fired (or so I understand). Perhaps the third time’s a charm; perhaps not.

It would be an easy book to adapt, and it would make for a better southern gothic piece by far than anything that I’m not going to name here but have seen recently and was disappointed by.

Ah, well.

Last Modified on August 26, 2005
this article New Things

4 thoughts on “New Things

    li class="comment even thread-even depth-1" id="comment-41">

    Ah. So I assume I don’t need to email you my scan of your review, then? I just got this month’s RoF in today’s mail . . .

    li class="comment odd alt thread-odd thread-alt depth-1" id="comment-42">

    This has nothing to do with this post, I just wanted to say that I’m having trouble browsing here sometimes. I keep getting just a blank screen, unless I hit enter in the address bar and try and reload you. (Like your page sort of poops out in the middle of loading – I see the title change in the window and nothing more.)

    I can’t see Greg’s page at all, so I’m thinking his website just doesn’t like me. :(

    Oh…and in case you care…my blog moved to the old url still works, I’ve set it up to forward, but thought I’d let you know.

    li class="comment even thread-even depth-1" id="comment-43">

    Cyndy – The server has been running a bit slow lately, that might have been causing it. It seems to be back up to speed now though… hopefully your issues should be fixed.

    li class="comment odd alt thread-odd thread-alt depth-1" id="comment-44">

    Yeah…seems to be working a bit better. Thanks for the heads up, Greg!

Leave a Reply

Your email address will not be published. Required fields are marked *